MK4-V WiXHC не выключает аутпут

Mach, популярные и не очень CAD, CAM. Обсуждение и разработка программ для управления станками.
tsipa740
Кандидат
Сообщения: 88
Зарегистрирован: 16 июн 2020, 00:09
Репутация: 6
Настоящее имя: Sergei
Контактная информация:

MK4-V WiXHC не выключает аутпут

Сообщение tsipa740 »

Здравствуй форум.
У меня вот такой контроллер https://www.nvcnc.net/MKV/MKX-V-Wiring- ... iagram.pdf
хочу сделать чтобы туман сам включался и выключался, взял соленоид для компрессора и солид стейт реле. Натыкал кнопки в маке чтобы мист-кулант включали релюшку. Всё вроде хорошо, но только почему-то оно не хочет релюшку выключать. Аналогичная картина если использовать меню конфигурации плагина - включить он включает, но выключить не может.
Кто-нибудь владеет таким-же контроллером и имеет при этом аутпут какой-нибудь задействованный? Это хардварная проблема или софтварная? Если у кого работает можете глянуть какая версия плагина у вас стоит?

https://youtu.be/V6tXYJ_8cSo
Евжений
Мастер
Сообщения: 867
Зарегистрирован: 05 апр 2016, 20:18
Репутация: 83
Настоящее имя: Жэзэрэл
Откуда: Там, сям.
Контактная информация:

Re: MK4-V WiXHC не выключает аутпут

Сообщение Евжений »

Реле убери. Без реле тоже залипает?
На других выходах без реле тоже залипает?
Аватара пользователя
Kachik
Мастер
Сообщения: 1013
Зарегистрирован: 13 янв 2017, 16:22
Репутация: 213
Настоящее имя: Сергей
Откуда: Питер
Контактная информация:

Re: MK4-V WiXHC не выключает аутпут

Сообщение Kachik »

У меня такой контроллер. Использую один из выходов. Работает и на вкл и на выкл нормально. Попробуй другой выход.
steals_y2k
Мастер
Сообщения: 354
Зарегистрирован: 29 окт 2017, 14:08
Репутация: 28
Настоящее имя: Makc
Откуда: Ярославль
Контактная информация:

Re: MK4-V WiXHC не выключает аутпут

Сообщение steals_y2k »

притянуть ногу выходного сигнала к земле? 🙄
tsipa740
Кандидат
Сообщения: 88
Зарегистрирован: 16 июн 2020, 00:09
Репутация: 6
Настоящее имя: Sergei
Контактная информация:

Re: MK4-V WiXHC не выключает аутпут

Сообщение tsipa740 »

Ну другие ноги я понятное дело пробовал, результат тот-же.
Евжений писал(а): Реле убери
Я это не пробовал и неожиданно дало много ценной информации. Убрал реле и оно начало работать как надо.
Причём магия случается если с реле включить, убрать ногу от реле, померять/поставить ногу к реле обратно.

В выключенном состоянии там 13к.ом, это примерно 20ма при 24в, в инструкции написано что на аутпут можно до 100ма. Может там у включённой это релюхи другое сопротивление и может тока много, у меня под рукой не оказалось мультиметра нормального чтобы ток померять и резисторов чтобы попробовать его поменять.

Через пару часов ещё раз попробую.
Евжений
Мастер
Сообщения: 867
Зарегистрирован: 05 апр 2016, 20:18
Репутация: 83
Настоящее имя: Жэзэрэл
Откуда: Там, сям.
Контактная информация:

Re: MK4-V WiXHC не выключает аутпут

Сообщение Евжений »

steals_y2k писал(а): притянуть ногу выходного сигнала к земле?
Кроме утечки ничего в голову не приходит. Значит надо подтягивать. Реле всего от 3 вольт начинает работать. Ему совсем маленький ток нужен чтобы оставаться открытым.
tsipa740
Кандидат
Сообщения: 88
Зарегистрирован: 16 июн 2020, 00:09
Репутация: 6
Настоящее имя: Sergei
Контактная информация:

Re: MK4-V WiXHC не выключает аутпут

Сообщение tsipa740 »

Ну без резистора там 30ма, поставил 2кома вот так вот
20210606_114231.jpg (178 просмотров) <a class='original' href='./download/file.php?id=195914&sid=49939da7241e57972a2d92b618dc9cfc&mode=view' target=_blank>Загрузить оригинал (1.42 МБ)</a>
и оно работает нормально.

Подтягивать вверх попробовал, но не работает. Что именно подтягивать вниз я честно говоря не понял - там аутпуты это 0, а +24 общий.
ou.png (178 просмотров) <a class='original' href='./download/file.php?id=195916&sid=49939da7241e57972a2d92b618dc9cfc&mode=view' target=_blank>Загрузить оригинал (166.49 КБ)</a>
Евжений
Мастер
Сообщения: 867
Зарегистрирован: 05 апр 2016, 20:18
Репутация: 83
Настоящее имя: Жэзэрэл
Откуда: Там, сям.
Контактная информация:

Re: MK4-V WiXHC не выключает аутпут

Сообщение Евжений »

Это не подтяжка, как токоограничивающий резистор стоит, последовательно.
Аватара пользователя
xvovanx
Мастер
Сообщения: 2954
Зарегистрирован: 25 фев 2016, 12:27
Репутация: 735
Настоящее имя: Владимир
Откуда: Latvia
Контактная информация:

Re: MK4-V WiXHC не выключает аутпут

Сообщение xvovanx »

tsipa740 писал(а): Если у кого работает
Как вы подключаете свое реле, учитываете что выходы платы с ОК?
П.С. в видео нет полной информации.
kfmut
Мастер
Сообщения: 280
Зарегистрирован: 30 янв 2021, 21:34
Репутация: 27
Контактная информация:

Re: MK4-V WiXHC не выключает аутпут

Сообщение kfmut »

Схема подключения другая же должна быть?
Screen-2021-06-06_22-48-25.png (163 просмотра) <a class='original' href='./download/file.php?id=195917&sid=49939da7241e57972a2d92b618dc9cfc&mode=view' target=_blank>Загрузить оригинал (61.61 КБ)</a>
https://pdf1.alldatasheet.com/datasheet ... -10DD.html
tsipa740
Кандидат
Сообщения: 88
Зарегистрирован: 16 июн 2020, 00:09
Репутация: 6
Настоящее имя: Sergei
Контактная информация:

Re: MK4-V WiXHC не выключает аутпут

Сообщение tsipa740 »

Евжений писал(а): 06 июн 2021, 22:18 Это не подтяжка, как токоограничивающий резистор стоит, последовательно.
Ну да, я же говорю - подтягивать как-то не помогло, это ток с 30ма до 5ма опустил и неясным мне образом стало работать.

Подтягивал я вот так вот.
20210606_135519.jpg (149 просмотров) <a class='original' href='./download/file.php?id=195918&sid=49939da7241e57972a2d92b618dc9cfc&mode=view' target=_blank>Загрузить оригинал (3.17 МБ)</a>
резистором толи на 500ком, толи на 1000.
На картинке повер аут и kz-com у них общая шина и по идее должно быть норм. Хз, может надо нормально попробовать как-то переделать - прям перед реле поставить, но чот не очевидна разница.
Вложения
eban3.png (149 просмотров) <a class='original' href='./download/file.php?id=195919&sid=49939da7241e57972a2d92b618dc9cfc&mode=view' target=_blank>Загрузить оригинал (89.8 КБ)</a>
tsipa740
Кандидат
Сообщения: 88
Зарегистрирован: 16 июн 2020, 00:09
Репутация: 6
Настоящее имя: Sergei
Контактная информация:

Re: MK4-V WiXHC не выключает аутпут

Сообщение tsipa740 »

Ну я сделал вот так, без всяких там допущений и срезаний углов, и всёравно не работает.
Я понимаю что дело именно в том что там нужно сигнал уточнить как-то и понимаю что понизив силу тока и просто замаскировал проблему и скорее всего сделал её плавающей и оставлять так не хочу. Объясните плз где я туплю?
argh.png (140 просмотров) <a class='original' href='./download/file.php?id=195920&sid=49939da7241e57972a2d92b618dc9cfc&mode=view' target=_blank>Загрузить оригинал (569.5 КБ)</a>
Kost_irk
Мастер
Сообщения: 339
Зарегистрирован: 19 июл 2018, 07:46
Репутация: 56
Откуда: Иркутск
Контактная информация:

Re: MK4-V WiXHC не выключает аутпут

Сообщение Kost_irk »

Смотрите пост kfmut, первая схема. При этом транзистор у вас внутри платы. Осталось подключить резистор между +24 и out, параллельно реле.
tsipa740
Кандидат
Сообщения: 88
Зарегистрирован: 16 июн 2020, 00:09
Репутация: 6
Настоящее имя: Sergei
Контактная информация:

Re: MK4-V WiXHC не выключает аутпут

Сообщение tsipa740 »

Мне _кажется_ что я так тоже уже пробовал. Но вообще на всякий решил попробовать ещё раз.
Ну так ведь как на картинке? Почему-то оно не хочет выключаться всёравно.
Вложения
20210606_214705.jpg (116 просмотров) <a class='original' href='./download/file.php?id=195922&sid=49939da7241e57972a2d92b618dc9cfc&mode=view' target=_blank>Загрузить оригинал (3.3 МБ)</a>
Аватара пользователя
xvovanx
Мастер
Сообщения: 2954
Зарегистрирован: 25 фев 2016, 12:27
Репутация: 735
Настоящее имя: Владимир
Откуда: Latvia
Контактная информация:

Re: MK4-V WiXHC не выключает аутпут

Сообщение xvovanx »

tsipa740 писал(а): Объясните плз где я туплю?
Все правильно сделали - реле подключили в коллекторную цепь и резистором притянули коллектор к нулю. Дело в том что эти электронные реле на входе имеют входные транзисторы, очень чувствительны и иногда ложно срабатывают даже от статики только на одном входе. Поэтому при отключении в плате коллектор вых. тр-ра остается висеть в воздухе (высокоимпедансное состояние), а релюшке достаточно даже тока утечки чтоб оставаться включенным. Если поставить обычное электромеханическое реле, то эти все танцы с бубнами уже не понадобятся.
tsipa740
Кандидат
Сообщения: 88
Зарегистрирован: 16 июн 2020, 00:09
Репутация: 6
Настоящее имя: Sergei
Контактная информация:

Re: MK4-V WiXHC не выключает аутпут

Сообщение tsipa740 »

Ну я реально не смог заставить солид стейт реле работать нормально, пришлось механическое поставить.
Спасибо за помощь джентльмены.
Ответить

Вернуться в «Windows / Mach»