команда PRESETON на стойке с SINUMERIK 840D SL

Fanuc, Okuma, Sinumerik и т.д.

команда PRESETON на стойке с SINUMERIK 840D SL

Сообщение G_DV » 26 окт 2018, 12:26

Здравствуйте!
Проблема с выполнением команды PRESETON на станке с системой SINUMERIK 840D SL v.1.4. Эта команда выполняется, но ведет себя очень странно. Судя по описанию, она должна просто присвоить выбранной оси (или осям) некое заданное значение, указанное в этой команде. Например, PRESETON(X,0) - оси X присваивается текущая координата 0 с потерей реферирования данной оси и всё. Однако в реале команда выполняется на одном и том же станке по-разному и отчего это зависит совершенно не понятно. Иногда она выполняется правильно, как по описанию, а иногда, чаще всего (но не всегда) после сброса NCK, вместо заданной в этой команде координаты заносит совершенно другое значение, затем по прошествии иногда небольшого времени (несколько минут) команда начинает выполнять на этом же станке правильно (но не всегда). Удалось лишь заметить, что к заданному в команде числу прибавляется некое число, которое берётся предположительно (?) из буфера неких присваиваемых значений для оси (типа MD34100 или что-то вроде этого). Не замечено, что бы на это влияло выполнение каких-либо других команд, например, G-группы. То есть, на данный момент совершенно не понятно что именно влияет на такое разное поведение команды. Может, кто-нибудь сталкивался с аналогичной проблемой и имеет какие-то реальные мысли на этот счёт? Буду благодарен.
G_DV
Новичок
 
Сообщения: 1
Зарегистрирован: 26 окт 2018, 11:58
Репутация: 0

Вернуться в Промышленные стойки

Кто сейчас на конференции

Зарегистрированные пользователи: Adskiydart, Bing [Bot], Cheslau, CNCCLUB, Dezman, dpss-2, Enot_1, galexey, Google [Bot], Hanter, iMaks-RS, john1987887, Kachik, kts, master_70, mikehv, Morze, nik0, nik0954, nik1, Pavelchr, pm_dev, Q-starь, Rom327, stiks, Taganrog, Vadim45, vovafed, Yandex [bot]

Reputation System ©'